• Ethun Hunt
  • 20 Points
  • Member since 2023

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 20

Hi Experts! 

I'd like to know if there's a way we can use the Aura Request Event Type from the Event Monitoring App? It seem that there's no prebuild Data Set for Aura Request Event Type.

We tried to create a Recipe using EventLogFile Object to pull the Aura Request fields (Run Time, CPU Time, DB Total Time, etc) but it only gives us limited fields.

EventLogFile Object 
It seem that the fields we're looking for is only available on ELF Browser (https://salesforce-elf.herokuapp.com/), however it is only raw file data in .csv file. We would like to use this data in our Event Monitoring App but it seems inconvenience if we reimport the csv file everytime we need to monitor the data. 

Any advice or workaround to monitor the Aura Request dynamically in the Event Monitoring App? Appreciate for the help, thank you!

Hi Community,

I created a button to create a new lead record with predefined field values for the name of this record, which combination of values from 2 fields. So when I test with test cases with both values of the fields are long, this combination values exceeded the field limit (120 characters). I edit the field to a shorter values, but it still unable to save and it still says it is exceeded the limit. 

I test with a test case where values from 2 fields are short and the combination of the 2 fields does not exceed for the limit for the field, but then I edit the field to a different value, it is able and successfully saved. 

My question is: why is this issue is appear? Is there any other way to fix this other than icreasing the limit of the field or make the limit for those 2 fields shorter?


I am retrieving the image via its link to the visualforce page as :


It works on desktop but when I open the page from a mobile device via safari or chrome, I don't see the image, could someone please help me to fix it ? Thanks.

We have used workplans and worksteps to implement safety assessment for field service technician. If technician works on France territory he will be asked question based on France territory. We achieved this using work plan selection rule. Whenever workorder is created automatically workplans and worksteps are added based on territory. But I want him to answer the same question in his native language. Question to be shown in his native language. If we create template based on language having selection rule for territory all the templates are now visible to technician. How to filter based on language in workplan component. So he can answer only question based on his language.

Hello Everyone,
I'm new to salesforce and I'm looking for a REST API from which I can retrieve the current state of some settings on my environment,
1. User Management Settings, which can be found here

2. Territory Settings, which can be found here 

3. Email Deliverability Settings, which can be found here

4. Configure Email Attachment Settings, which can be found here 

Thanks for reading this, If you even know where can I find any of these please share, I highly appreciate your help :)


How does application development work and how does development affect the cost of the application? What does it depend on? I want to develop my own application and I don't know if I have enough budget. Is there any way to calculate the cost of developing an application in advance?
Before I forget these were the exact steps I took to finally make it work.

  • Clean up your current installations:
  • Delete Folders .sf  and .sfdx and local installation
  • Uninstall all your previous versions of node and python
  1. Make sure you have Python 3 installed
    1. During NPM Install of Plugin, it will look for a version of Python installed, else it will fail
  2. Install NodeJS LTS 18
    1. Install Node-Gyp using NPM Install command (NPM comes with NodeJS)
    2. Otherwise, the NPM installation of the Plugin will automatically install NODE-GYP for you
Install SF CLI
  • Install SF CLI using NPM!!!!!!  not the stupid Windows MSI Installer
    • https://developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/sfdx_setup/sfdx_setup_install_cli.htm#sfdx_setup_install_cli_npm
    • NPM is a two step process
      • Install .sfdx
      • Install .sf
  • After you have installed .sf and .sfdx  (This will get you the latest version)
  • Test it by connecting to your Sandbox
    • If you can't authenticate using standard web login try this
      • sfdx force:auth:device:login --instanceurl <your custom or test.salesforce.com> --setdefaultusername
      • This will display a user code within the cmd window
      • Enter that Code after  you open 
      • YOU MUST Enter the URL that you started with
      • https://<The URL You specified above>/setup/connect in a browser
Now here is the FUN
Several repeat steps were needed

Step1: sfdx plugins:install @salesforce/lwc-dev-server 
  • This will fail with that stupid YARN Error Message
Step2: npm install -g @salesforce/lwc-dev-server
  • This will properly install Node-Gyp for you
  • It will also pass the python check sinced you installed it at the very beginning
  • gyp info it worked if it ends with ok
    gyp info using node-gyp@9.3.1
    gyp info using node@18.16.0 | win32 | x64
    gyp info find Python using Python version 3.11.3 found at "C:\Python311\python.exe"
  • But it will Burp about not having Visual Studio
    • 7756 error gyp ERR! find VS could not use PowerShell to find Visual Studio 2017 or newer, try re-running with '--loglevel silly' for more details
      7756 error gyp ERR! find VS looking for Visual Studio 2015
      7756 error gyp ERR! find VS - not found
      7756 error gyp ERR! find VS not looking for VS2013 as it is only supported up to Node.js 8
      7756 error gyp ERR! find VS 
      7756 error gyp ERR! find VS **************************************************************
      7756 error gyp ERR! find VS You need to install the latest version of Visual Studio
      7756 error gyp ERR! find VS including the "Desktop development with C++" workload.
    • RUN npm install --global windows-build-tools
      •  This will also FAIL, but it downsloads the VS17 exe file for you
      • This is saved in
      • C:\Users\your name\.windows-build-tools\vs_BuildTools.exe
      • Install it and MAKE SURE YOU Select
      • VS including the "Desktop development with C++" workload.
Step3: RUN IT AGAIN npm install -g @salesforce/lwc-dev-server
  • This time it will detect Python and the Version of Visual Studio 17
  • It will load all the packages with no errors, but the plug in is still not installed
  • you will see something like this
  • added 1218 packages, and changed 1 package in 7m
    102 packages are looking for funding
Step4: RUN IT AGAIN the SFDX command PLUGIN again
  • sfdx plugins:install @salesforce/lwc-dev-server 
    • @salesforce/lwc-dev-server... \ [2/4] Fetching packages...
      warning "@salesforce/lwc-dev-server > @rollup/plugin-alias@3.1.9" has unmet peer dependency "rollup@^1.20.0||^2.0.0".
      warning "@salesforce/lwc-dev-server > request-promise-native@1.0.9" has unmet peer dependency "request@^2.34".
      warning "@salesforce/lwc-dev-server > request-promise-native > request-promise-core@1.1.4" has unmet peer dependency "reqInstalling plugin @salesforce/lwc-dev-server... installed v2.11.0

In Summary
Python 3
Nodejs 18 LTS
Visual Studio 17 and Desktop Build
Multiple Plug-in Install steps
(See my step by step above)


Anyways, I HOPE THIS IS Useful, because I scoured the internet for answers.  TRUST ME.  All the answers had some truth, but none worked for me.  UNTIL THIS DAY!!!!!

Hi there,

I have added an image in the pre-chat additional setting. The image displays on a desktop web browser but it does not display on a mobile browser. The Chatbot window increased because the background image is added but it displays as a blank space on a mobile browser

Has anyone experienced this and was able to resolve this issue?

Suppose I have a community 
It has 3 profiles and each profile has some users
1.Profile : Direct Sales User  :  10 Users
2.Profile : Indirect Sales User  : 4 user
3.Profile :  Corporrate Sales User :  50 users

So If I want to convert https://mycommunitysalesuser.com into mobile publisher app
I want only Profile : Direct Sales User  to use mobile publisher app 
Then how does the salesforce license charges , is it for 10 users or all users of the community ?
I have been developing lwc component for salesforce mobile. I would like to know the code on how to know user has pressed back button

At our company we're using the embedded ServiceSDK for iOS (version 238.0.0) https://developer.salesforce.com/docs/atlas.en-us.service_sdk_ios.meta/service_sdk_ios/servicesdk_ios_dev_guide.htm

After the release of iOS 15 we have seen a lot of crashes in the Xcode Organizer for iOS 15 similar to the one in the stack trace below. After investigating we tend to think this is happening during the new iOS 15 prewarm.

Documentation from Apple: https://developer.apple.com/documentation/uikit/app_and_environment/responding_to_the_launch_of_your_app/about_the_app_launch_sequence#3894431


If anyone has an idea of what could be done to fix this I'd very much like to hear about it.

Incident Identifier: 271E4C3E-E7ED-4C20-BE70-D2E749D181D8
Hardware Model:      iPhone12,1
Process:             [redacted] [990]
Path:                /private/var/containers/Bundle/Application/7AE6B709-FA88-4D0B-A83F-323CFD2ED40E/[redacted].app/[redacted] 
Identifier:          com.[redacted] 
Version:             2022.7.0 (11)
AppStoreTools:       13C90b
Code Type:           ARM-64 (Native)
Role:                unknown
Parent Process:      launchd [1]
Coalition:           com.[redacted]  [746]

Date/Time:           2022-05-18 14:30:01.3969 -0400
Launch Time:         2022-05-18 14:29:51.7742 -0400
OS Version:          iPhone OS 15.3.1 (19D52)
Release Type:        User
Baseband Version:    3.01.02
Report Version:      104

Exception Type:  EXC_CRASH (SIGKILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note:  EXC_CORPSE_NOTIFY
Termination Reason: FRONTBOARD 2343432205 
<RBSTerminateContext| domain:10 code:0x8BADF00D explanation:process-launch watchdog transgression: application<com.[redacted] >:990 exhausted CPU time allowance of 5.00 seconds
ProcessVisibility: Background
ProcessState: Running
WatchdogEvent: process-launch
WatchdogVisibility: Background
WatchdogCPUStatistics: (
"Elapsed total CPU time (seconds): 20.660 (user 20.660, system 0.000), 36% CPU",
"Elapsed application CPU time (seconds): 5.537, 10% CPU"
) reportType:CrashLog maxTerminationResistance:Interactive>

Triggered by Thread:  0

Thread 0 name:
Thread 0 Crashed:
0   libsystem_kernel.dylib          0x00000001b8634d90 __open + 8
1   libsystem_kernel.dylib          0x00000001b8635174 open + 40 (open-base.c:101)
2   CoreFoundation                  0x00000001810c0070 _CFReadBytesFromFile + 180 (CFFileUtilities.c:96)
3   CoreFoundation                  0x00000001810882f4 CFURLCreateDataAndPropertiesFromResource + 316 (CFURLAccess.c:277)
4   CoreFoundation                  0x0000000181095b90 _CFBundleCopyInfoDictionaryInDirectoryWithVersion + 848 (CFBundle_InfoPlist.c:861)
5   CoreFoundation                  0x000000018106b7b0 _CFBundleRefreshInfoDictionaryAlreadyLocked + 144 (CFBundle_InfoPlist.c:1106)
6   CoreFoundation                  0x0000000181088194 CFBundleGetInfoDictionary + 52 (CFBundle_InfoPlist.c:1120)
7   CoreFoundation                  0x000000018109b9c8 _CFBundleCreate + 472 (CFBundle.c:903)
8   Foundation                      0x00000001828aac04 -[NSBundle _cfBundle] + 76 (NSBundle.m:181)
9   Foundation                      0x00000001828ed78c -[NSBundle infoDictionary] + 24 (NSBundle.m:1200)
10  Foundation                      0x00000001828d3b08 -[NSBundle bundleIdentifier] + 24 (NSBundle.m:1116)
11  Foundation                      0x000000018288cb1c -[NSObject(NSKeyValueCoding) valueForKey:] + 320 (NSKeyValueCoding.m:417)
12  Foundation                      0x00000001828c8ea4 -[NSFunctionExpression expressionValueWithObject:context:] + 1496 (NSFunctionExpression.m:378)
13  Foundation                      0x00000001828b29fc -[NSComparisonPredicate evaluateWithObject:substitutionVariables:] + 216 (NSComparisonPredicate.m:299)
14  Foundation                      0x00000001828cfa20 _filterObjectsUsingPredicate + 264 (NSPredicateCategories.m:27)
15  Foundation                      0x00000001828b7f5c -[NSArray(NSPredicateSupport) filteredArrayUsingPredicate:] + 196 (NSPredicateCategories.m:44)
16  ServiceCore                     0x000000010760b4a0 initialize_framework_bundles + 204
17  dyld                            0x0000000101740794 ___ZNK5dyld46Loader25findAndRunAllInitializersERNS_12RuntimeStateE_block_invoke + 164 (Loader.cpp:1273)
18  dyld                            0x0000000101774510 ___ZNK5dyld313MachOAnalyzer18forEachInitializerER11DiagnosticsRKNS0_15VMAddrConverterEU13block_pointerFvjEPKv_block_invoke.310 + 168 (MachOAnalyzer.cpp:3182)
19  dyld                            0x000000010173e428 ___ZNK5dyld39MachOFile14forEachSectionEU13block_pointerFvRKNS0_11SectionInfoEbRbE_block_invoke + 532 (MachOFile.cpp:1302)
20  dyld                            0x000000010173d678 dyld3::MachOFile::forEachLoadCommand(Diagnostics&, void (load_command const*, bool&) block_pointer) const + 168 (MachOFile.cpp:929)
21  dyld                            0x000000010173c9d0 dyld3::MachOFile::forEachSection(void (dyld3::MachOFile::SectionInfo const&, bool, bool&) block_pointer) const + 192 (MachOFile.cpp:1261)
22  dyld                            0x0000000101774098 dyld3::MachOAnalyzer::forEachInitializerPointerSection(Diagnostics&, void (unsigned int, unsigned int, unsigned char const*, bool&) block_pointer) const + 148 (MachOAnalyzer.cpp:3086)
23  dyld                            0x0000000101749dc0 dyld3::MachOAnalyzer::forEachInitializer(Diagnostics&, dyld3::MachOAnalyzer::VMAddrConverter const&, void (unsigned int) block_pointer, void const*) const + 432 (MachOAnalyzer.cpp:3171)
24  dyld                            0x0000000101746968 dyld4::Loader::findAndRunAllInitializers(dyld4::RuntimeState&) const + 172 (Loader.cpp:1265)
25  dyld                            0x0000000101742344 dyld4::Loader::runInitializersBottomUp(dyld4::RuntimeState&, dyld3::Array<dyld4::Loader const*>&) const + 208 (Loader.cpp:1305)
26  dyld                            0x0000000101742320 dyld4::Loader::runInitializersBottomUp(dyld4::RuntimeState&, dyld3::Array<dyld4::Loader const*>&) const + 172 (Loader.cpp:1296)
27  dyld                            0x00000001017484b0 dyld4::Loader::runInitializersBottomUpPlusUpwardLinks(dyld4::RuntimeState&) const + 124 (Loader.cpp:1315)
28  dyld                            0x0000000101768124 dyld4::APIs::runAllInitializersForMain() + 320 (DyldAPIs.cpp:3391)
29  dyld                            0x0000000101753508 dyld4::prepare(dyld4::APIs&, dyld3::MachOAnalyzer const*) + 3024 (dyldMain.cpp:738)
30  dyld                            0x0000000101751a84 start + 488 (dyldMain.cpp:864)
We have configured single sign on and want users to login to salesforce through SSO when using the salesfrce mobile app. Users have installed the salesforce app on their mobile device and when they click the single sign on button, it asks users to 'To enroll your device, install the free Microsoft Intune Company Portal app'. However the Intune app is already installed by default for users in our org.
Has anyone else had this issue or something similar when trying to login to the salesforce mobile app and figured out a workaround?

Steps followed to reproduce:
Method 1 : Login with username and password (Salesforce credentials), works fine.
Method 2 : Go to Salesforce Mobile app

• Change the custom domain to company name, so we get the SSO button to appear on the mobile app and login through SSO
• When we click the SSO link, it redirects to Microsoft login page.
• Primary authentication is successful, and we are receiving an authentication notification on Microsoft Authenticator.
• On clicking on Approve, it re-directs to Play Store to install Microsoft Intune Company Portal.
• Microsoft InTune is already installed on the Mobile Devices.
• Devices tested : Windows 10 laptop, Android Mobile Device, Iphone.
We have tried the following:
  • Deactivated Google Chrome on Android device, no luck with the default browser.
  • Updated the InTune policies, no luck.
  • Windows 10 device is updated with the latest sync policies, no luck.
  • Checked the domain settings in salesforce to 'Use the native browser for user authentication on iOS and Android'. No luck.
  • We raised it with our Microsoft team to investigate. They have indicated that it is an issue with the salesforce mobile app.
Any info would be much appreciated. 


Is there a posibility to attach image files to case form using mobile sdk?


I am getting the following error:
sampleVendor: Not available for deploy for this organization
VoiceCall: Invalid fullName, must end in a custom suffix ( for ex. __c )
Service_Cloud_Voice: In field: pageOrSobjectType - no CustomObject named VoiceCall found
and another error saying that the voicecall object is invalid (the msg is originally in another language)
when following this step:
Create a Package Version
sfdx force📦version:create --package "" --codecoverage --installationkeybypass --wait 20
in this guide (https://developer.salesforce.com/docs/atlas.en-us.voice_pt_developer_guide.meta/voice_pt_developer_guide/voice_pt_deploy_package.htm).
Can you tell me what is wrong? I think I follow every previous step in the guide.

We are developing a canvas app and trying to test it in the Salesforce app in mobile. But we are seeing some issue that only happens in IOS devices:
1) Information cut off issue: We are using window.innerHeight to determine the canvas size in mobile. It works perfectly in Android device but a certain page has some information cut off in IOS device.(Other pages in our app perfectly fit in the same IOS device)
2) Canvas app not loading in IOS devices: We also have another app(call it app B) that is connected to the app mentioned above and app B loads fine in Android device but not load in the IOS device.

Does anyone know anything about this issue?

Can someone guide me step by step.
How can we integrate Einstein Bot with whatsapp?
I have 2 custom objects that have a lookup relationship (think Account/Contact). When I create a new Contact record, I am able to enter a pre-existing Account in the lookup Account field OR click the "+ New Account" option if the Account doesn't already exist. This allows me to create a new Account record while I'm creating a new Contact record. 

I am unable to do this in Salesforce Mobile. If the Account doesn't already exist, I have no option of creating a new Account from the new Contact record page. I would have to go to the Account object separately and create a new Account record; then it will allow me to enter a pre-existing Account name into the lookup Account field. How do I solve this? 

Thanks in advance! 
How we can get WhatsAPP Api key

I am working in enterprise edition. As winter 14 changed... i am unable to see the option reset security token . In devoloper edition it is visible. So from Enterprise edition i am unable to find.

  • December 16, 2013
  • Like
  • 2